Problem Description:
When performing a file backup, the following error message is received in the backup report:
No. |
Type |
Timestamp |
Backup Logs |
1 |
Info |
YYYY/MM/DD hh:mm |
Start [ Windows platform (Test),ServosityPro 5.x.x.x ] |
2 |
Info |
YYYY/MM/DD hh:mm |
Start running pre-commands |
3 |
... |
... |
... |
* |
Error |
YYYY/MM/DD hh:mm |
[Shadow Copy] Snap Shot for Shadow Copy set is missing, backup terminate. |
Upon further investigation, the following error messages is found in the Application / System logs of Event Viewer:
Event Type: Error
Event ID: 12
Description:
The shadow copy of volume C: became low on diff area space before it was properly installed.
or
Event Type: Error
Event ID: 25
Description:
The shadow copy of volume C: was aborted because the diff area file could not grow in time.
Consider reducing the IO load on this system to avoid this problem in the future.
Notes:
Checker Event Viewer can be located by clicking on [Start] -> [Settings] -> [Control Panel] -> [Administrative Tools] -> [Event Viewer].
Cause:
The message suggests that VSS was unable to create the image in time for the backup. Furthermore, the messages found in the Event Viewer suggest that the disk activity was high during the backup operation.
Example error message(s):
[Shadow Copy] Snap Shot for Shadow Copy set is missing, backup terminate
Resolution:
Please verify if there is other application(s) running on the corresponding machine, which may require a high amount of disk resources. Alternatively, you can also re-schedule the backup job to be performed when disk usage is low.
This can often be due to a lack of RAM and the reason this error comes up is because the affected machine is trying to increase the Virtual Memory size and by doing so increases the I/O load on the disk. If you view the Event Viewer (Control Panel > Administrative Tools > Event Viewer) and look through the System/Application logs, you will also note errors that indicate I/O problems.
An upgrade of RAM is recommended, otherwise if this is not an option then to tweak the Virtual Memory settings to cater for the larger amount of memory required.
Related Links:
http://support.servosity.com/entries/81620227-Microsoft-VSS-Troubleshooting