- Product Version:
Servosity Std: All
Servosity Pro: All
OS: Windows
Servosity Pro: All
OS: Windows
- Problem Description:
When performing a file backup, the following informative message is received in the backup report:
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- Cause:
The message suggests that during the uploading stage of a backup job, the corresponding file(s) identified in the file comparison stage no longer exists on the client machine. This usually happens to temporary file(s) that is created and removed frequently.
To further explain, when a backup job is started, the following actions are performed by Servosity Pro.
1. Pre-command(s)
2. Create Volume Shadow Copy (if necessary)
3. Download the remote file list from the Servosity Backup server
4. Compare the local files with the remote file list determine the list of file(s) to be uploaded
5. Upload the data listed in Step 4
6. Post-command(s)
7. Remove the created Volume Shadow Copy
The message "...has been removed already" is flagged when a file(s) that was listed in the local file list (Step 4) no longer exists on the client machine in the file upload stage (Step 5).
Furthermore, this problem can also occurs if an incorrect Volume Shadow Copy snapshot of the file has been created, or if the affected file is not included in the Volume Shadow Copy snapshot.
Finally, for ServosityPro / ServosityStd version prior to 5.5.1.0, this issue can also occurs if the "Temporary directory for storing backup files" assigned for the affected backup set has been set to a directory that does not exist.
To further explain, when a backup job is started, the following actions are performed by Servosity Pro.
1. Pre-command(s)
2. Create Volume Shadow Copy (if necessary)
3. Download the remote file list from the Servosity Backup server
4. Compare the local files with the remote file list determine the list of file(s) to be uploaded
5. Upload the data listed in Step 4
6. Post-command(s)
7. Remove the created Volume Shadow Copy
The message "...has been removed already" is flagged when a file(s) that was listed in the local file list (Step 4) no longer exists on the client machine in the file upload stage (Step 5).
Furthermore, this problem can also occurs if an incorrect Volume Shadow Copy snapshot of the file has been created, or if the affected file is not included in the Volume Shadow Copy snapshot.
Finally, for ServosityPro / ServosityStd version prior to 5.5.1.0, this issue can also occurs if the "Temporary directory for storing backup files" assigned for the affected backup set has been set to a directory that does not exist.
- Resolution:
To resolve the issue, please follow the instructions below:
If In-file delta is enabled for the backup set in concern, please ensure that the "Temporary directory for storing backup files" setting of ServosityPro is set to a writable directory with sufficient disk space.
Please also verify if the file(s) in concern is temporary file. If it is, please un-select these files from the backup source to resolve the issue.
In the cases where the issue is caused by incorrect snapshot of Volume Shadow Copy, please follow the instructions below:
Windows XP / Vista:
To resolve the issue, please re-register the Volume Shadow Copy Service. To do so, you could utilize the "RegisterVSS.bat" script available in ${Install-Home}\bin. Please also reboot the machine afterward.
Notes:
Please safely ignore the error message(s) displayed during the re-registration, as some of the DLL files are platform specific.
Windows 2003:
To resolve the issue, please follow the instructions below:
Although, it is not an official recommendation from Microsoft, this key will get recreated after the machine is restarted.
Windows 2008:
To resolve the issue, please follow the instructions below:
If In-file delta is enabled for the backup set in concern, please ensure that the "Temporary directory for storing backup files" setting of ServosityPro is set to a writable directory with sufficient disk space.
Please also verify if the file(s) in concern is temporary file. If it is, please un-select these files from the backup source to resolve the issue.
In the cases where the issue is caused by incorrect snapshot of Volume Shadow Copy, please follow the instructions below:
Windows XP / Vista:
To resolve the issue, please re-register the Volume Shadow Copy Service. To do so, you could utilize the "RegisterVSS.bat" script available in ${Install-Home}\bin. Please also reboot the machine afterward.
Notes:
Please safely ignore the error message(s) displayed during the re-registration, as some of the DLL files are platform specific.
Windows 2003:
To resolve the issue, please follow the instructions below:
- Please backup the registry key -
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EventSystem\{26c409cc-ae86-11d1-b61600805fc79216}\Subscriptions - Remove this registry key along with all its sub-keys
- Reboot the machine
Although, it is not an official recommendation from Microsoft, this key will get recreated after the machine is restarted.
Windows 2008:
To resolve the issue, please follow the instructions below:
- Please download the "RegisterVSS2008.zip" file by Clicking Here
- Extract the zip file to ${Install-Home}\bin
- Execute the extracted script file
- Reboot the machine