Problem:
The problem you are most likely to encounter, is that users are unable to access files on a server after ShadowProtect has been installed. The Event Manager System event logs will show event ID 201 with the following message:
The server's configuration parameter "irpstacksize" is too small for the server to use as a local device. Please increase the value of the parameter.
Example Error Message:
29-Sep-2014 07:30:00 service 100 service (build 53) started job by incremental trigger
29-Sep-2014 07:30:00 service 104 5.0.0.22464 9619-E16B
08kduxbU9ajpqBvVWg2M8A== 105A-D64A-B98E-1838-2A04-665A-076F-5995
29-Sep-2014 07:30:00 service 100 backup volume C:\ (NTFS)
29-Sep-2014 07:30:00 service 509 Cannot get access to destination object
29-Sep-2014 07:30:00 service 101 Cannot execute job (Not enough server storage is available to process this command. 0x8007046A(2147943530))
Cause:
Additional errors may also occur in the ShadowProtect backup logs and backup history. These logs report that there is insufficient system resources to complete a task or a command. In this situation the Event 2011 may or may not occur.
Resolution:
This is a common problem on servers with lots of storage. Windows does not dynamically adjust the irpstacksize beyond a value of 15 in most cases. For servers with a large number of file system drivers, you will need to increase this value manually.
If you are running other applications (such as a virus scanner) there is probably limited IRP stack space left. Each application that uses a driver, including the OS, will use up the IRP stack. The more storage on the system, the more IRP stack space these applications will use. Since the server is probably close to the limit, ShadowProtect will have pushed the server over the limit and other services may have started to fail.
Please read the following Microsoft KB Articles before adjusting these values:
- http://support.microsoft.com/kb/106167 - Error message: "Not enough server storage is available to process this command"
- http://support.microsoft.com/kb/329717/en-us - Connectivity issues occur after you install Norton AntiVirus 7.5
- http://support.microsoft.com/kb/285089/en-us - Description of the IRPStackSize parameter in Windows 2000, in Windows XP, and in Windows Server 2003
- http://support.microsoft.com/kb/177078/en-us - Antivirus software may cause Event ID 2011
Regardless of whether your particular case fits any of the four links from Microsoft the inclusion of ShadowProtect to the system can produce this problem even if all four of the given reasons from Microsoft are not true.
http://www.storagecraft.com/support/kb/article/14